CVE Vulnerabilities

CVE-2001-1413

Published: Dec 23, 2004 | Modified: Jul 11, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

Stack-based buffer overflow in the comprexx function for ncompress 4.2.4 and earlier, when used in situations that cross security boundaries (such as FTP server), may allow remote attackers to execute arbitrary code via a long filename argument.

Affected Software

Name Vendor Start Version End Version
Ncompress Ncompress * 4.2.4
Red Hat Enterprise Linux 2.1 RedHat ncompress *
Ncompress Ubuntu dapper *

References