CVE Vulnerabilities

CVE-2003-0018

Published: Feb 19, 2003 | Modified: Sep 11, 2008
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
3.6 LOW
AV:L/AC:L/Au:N/C:P/I:N/A:P
RedHat/V2
RedHat/V3
Ubuntu

Linux kernel 2.4.10 through 2.4.21-pre4 does not properly handle the O_DIRECT feature, which allows local attackers with write privileges to read portions of previously deleted files, or cause file system corruption.

Affected Software

Name Vendor Start Version End Version
Linux_kernel Linux 2.4.10 2.4.10
Linux_kernel Linux 2.4.11 2.4.11
Linux_kernel Linux 2.4.12 2.4.12
Linux_kernel Linux 2.4.13 2.4.13
Linux_kernel Linux 2.4.14 2.4.14
Linux_kernel Linux 2.4.15 2.4.15
Linux_kernel Linux 2.4.16 2.4.16
Linux_kernel Linux 2.4.17 2.4.17
Linux_kernel Linux 2.4.18 2.4.18
Linux_kernel Linux 2.4.19 2.4.19
Kernel-source-2.4.27 Ubuntu dapper *
Kernel-source-2.4.27 Ubuntu edgy *

References