CVE Vulnerabilities

CVE-2003-0581

Published: Aug 18, 2003 | Modified: Oct 18, 2016
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

X Fontserver for Truetype fonts (xfstt) 1.4 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a (1) FS_QueryXExtents8 or (2) FS_QueryXBitmaps8 packet, and possibly other types of packets, with a large num_ranges value, which causes an out-of-bounds array access.

Affected Software

Name Vendor Start Version End Version
Xfstt Xfstt 1.2.1 1.2.1
Xfstt Xfstt 1.4 1.4
Xfstt Ubuntu dapper *
Xfstt Ubuntu devel *
Xfstt Ubuntu edgy *
Xfstt Ubuntu feisty *

References