CVE Vulnerabilities

CVE-2003-0630

Published: Oct 20, 2003 | Modified: Oct 18, 2016
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.2 HIGH
AV:L/AC:L/Au:N/C:C/I:C/A:C
RedHat/V2
RedHat/V3
Ubuntu

Multiple buffer overflows in the atari800.svgalib setuid program of the Atari 800 emulator (atari800) before 1.2.2 allow local users to gain privileges via long command line arguments, as demonstrated with the -osa_rom argument.

Affected Software

Name Vendor Start Version End Version
Atari800 Atari800 1.0.1 1.0.1
Atari800 Atari800 1.0.2 1.0.2
Atari800 Atari800 1.0.3 1.0.3
Atari800 Atari800 1.0.4 1.0.4
Atari800 Atari800 1.0.5 1.0.5
Atari800 Atari800 1.0.6 1.0.6
Atari800 Atari800 1.0.7 1.0.7
Atari800 Atari800 1.2 1.2
Atari800 Atari800 1.2.1 1.2.1
Atari800 Atari800 1.2.1_pre0 1.2.1_pre0
Atari800 Atari800 1.2.2 1.2.2

References