CVE Vulnerabilities

CVE-2003-0978

Published: Jan 05, 2004 | Modified: Jul 11, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

Format string vulnerability in gpgkeys_hkp (experimental HKP interface) for the GnuPG (gpg) client 1.2.3 and earlier, and 1.3.3 and earlier, allows remote attackers or a malicious keyserver to cause a denial of service (crash) and possibly execute arbitrary code during key retrieval.

Affected Software

Name Vendor Start Version End Version
Privacy_guard Gnu 1.2 1.2
Privacy_guard Gnu 1.2.1 1.2.1
Privacy_guard Gnu 1.2.2 1.2.2
Privacy_guard Gnu 1.2.2 1.2.2
Privacy_guard Gnu 1.2.3 1.2.3
Privacy_guard Gnu 1.3.3 1.3.3

References