CVE Vulnerabilities

CVE-2003-0986

Published: Dec 31, 2003 | Modified: Oct 11, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
1.7 LOW
AV:L/AC:L/Au:S/C:N/I:N/A:P
RedHat/V2
RedHat/V3
Ubuntu

Various routines for the ppc64 architecture on Linux kernel 2.6 prior to 2.6.2 and 2.4 prior to 2.4.24 do not use the copy_from_user function when copying data from userspace to kernelspace, which crosses security boundaries and allows local users to cause a denial of service.

Affected Software

Name Vendor Start Version End Version
Linux_kernel Linux 2.4.0 2.4.0
Linux_kernel Linux 2.4.0 2.4.0
Linux_kernel Linux 2.4.0 2.4.0
Linux_kernel Linux 2.4.0 2.4.0
Linux_kernel Linux 2.4.0 2.4.0
Linux_kernel Linux 2.4.0 2.4.0
Linux_kernel Linux 2.4.0 2.4.0
Linux_kernel Linux 2.4.0 2.4.0
Linux_kernel Linux 2.4.0 2.4.0
Linux_kernel Linux 2.4.0 2.4.0
Linux_kernel Linux 2.4.0 2.4.0
Linux_kernel Linux 2.4.18 2.4.18
Linux_kernel Linux 2.4.18 2.4.18
Linux_kernel Linux 2.4.18 2.4.18
Linux_kernel Linux 2.4.18 2.4.18
Linux_kernel Linux 2.4.18 2.4.18
Linux_kernel Linux 2.4.18 2.4.18
Linux_kernel Linux 2.4.18 2.4.18
Linux_kernel Linux 2.4.18 2.4.18
Linux_kernel Linux 2.4.18 2.4.18
Linux_kernel Linux 2.4.19 2.4.19
Linux_kernel Linux 2.4.19 2.4.19
Linux_kernel Linux 2.4.19 2.4.19
Linux_kernel Linux 2.4.19 2.4.19
Linux_kernel Linux 2.4.19 2.4.19
Linux_kernel Linux 2.4.19 2.4.19
Linux_kernel Linux 2.4.21 2.4.21
Linux_kernel Linux 2.4.21 2.4.21
Linux_kernel Linux 2.4.21 2.4.21
Linux_kernel Linux 2.4.22 2.4.22
Linux_kernel Linux 2.4.23 2.4.23
Linux_kernel Linux 2.4.23 2.4.23
Linux_kernel Linux 2.4.23_ow2 2.4.23_ow2
Linux_kernel Linux 2.4.24 2.4.24
Linux_kernel Linux 2.4.24_ow1 2.4.24_ow1
Linux_kernel Linux 2.6.0 2.6.0
Linux_kernel Linux 2.6.1 2.6.1
Linux_kernel Linux 2.6.1 2.6.1
Linux_kernel Linux 2.6.2 2.6.2
Enterprise_linux Redhat 3.0 3.0
Enterprise_linux Redhat 3.0 3.0
Enterprise_linux Redhat 3.0 3.0
Red Hat Enterprise Linux 3 RedHat kernel-0:2.4.21-9.EL *

References