CVE Vulnerabilities

CVE-2004-0063

Published: Feb 17, 2004 | Modified: Oct 10, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

The SPP_VerifyPVV function in nCipher payShield SPP library 1.3.12, 1.5.18 and 1.6.18 returns a Status_OK value even if the HSM returns a different status code, which could cause applications to make incorrect security-critical decisions, e.g. by accepting an invalid PIN number.

Affected Software

Name Vendor Start Version End Version
Payshield_spp_library Ncipher 1.3.12 1.3.12
Payshield_spp_library Ncipher 1.5.18 1.5.18
Payshield_spp_library Ncipher 1.6.18 1.6.18

References