CVE Vulnerabilities

CVE-2004-0093

Published: Mar 15, 2004 | Modified: Oct 10, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

XFree86 4.1.0 allows remote attackers to cause a denial of service and possibly execute arbitrary code via an out-of-bounds array index when using the GLX extension and Direct Rendering Infrastructure (DRI).

Affected Software

Name Vendor Start Version End Version
X11r6 Xfree86_project 4.1.0 4.1.0
X11r6 Xfree86_project 4.1.11 4.1.11
X11r6 Xfree86_project 4.1.12 4.1.12
X11r6 Xfree86_project 4.2.0 4.2.0
X11r6 Xfree86_project 4.2.1 4.2.1
X11r6 Xfree86_project 4.2.1 4.2.1
X11r6 Xfree86_project 4.3.0 4.3.0
Red Hat Enterprise Linux 2.1 RedHat XFree86 *
Xorg Ubuntu dapper *
Xorg Ubuntu devel *
Xorg Ubuntu edgy *
Xorg Ubuntu feisty *

References