CVE Vulnerabilities

CVE-2004-0409

Published: Jun 01, 2004 | Modified: Oct 11, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

Stack-based buffer overflow in the Socks-5 proxy code for XChat 1.8.0 to 2.0.8, with socks5 traversal enabled, allows remote attackers to execute arbitrary code.

Affected Software

Name Vendor Start Version End Version
Xchat Xchat 1.8.0 1.8.0
Xchat Xchat 1.8.1 1.8.1
Xchat Xchat 1.8.2 1.8.2
Xchat Xchat 1.8.3 1.8.3
Xchat Xchat 1.8.4 1.8.4
Xchat Xchat 1.8.5 1.8.5
Xchat Xchat 1.8.6 1.8.6
Xchat Xchat 1.8.7 1.8.7
Xchat Xchat 1.8.8 1.8.8
Xchat Xchat 1.8.9 1.8.9
Xchat Xchat 1.9.0 1.9.0
Xchat Xchat 1.9.1 1.9.1
Xchat Xchat 1.9.2 1.9.2
Xchat Xchat 1.9.3 1.9.3
Xchat Xchat 1.9.4 1.9.4
Xchat Xchat 1.9.5 1.9.5
Xchat Xchat 1.9.6 1.9.6
Xchat Xchat 1.9.7 1.9.7
Xchat Xchat 1.9.8 1.9.8
Xchat Xchat 1.9.9 1.9.9
Xchat Xchat 2.0.0 2.0.0
Xchat Xchat 2.0.1 2.0.1
Xchat Xchat 2.0.2 2.0.2
Xchat Xchat 2.0.3 2.0.3
Xchat Xchat 2.0.4 2.0.4
Xchat Xchat 2.0.5 2.0.5
Xchat Xchat 2.0.6 2.0.6
Xchat Xchat 2.0.7 2.0.7
Xchat Xchat 2.0.8 2.0.8
Red Hat Enterprise Linux 3 RedHat xchat-1:2.0.4-4.EL *
Red Hat Linux 9 RedHat xchat *
Xchat Ubuntu dapper *
Xchat Ubuntu devel *
Xchat Ubuntu edgy *
Xchat Ubuntu feisty *

References