CVE Vulnerabilities

CVE-2004-0768

Published: Oct 20, 2004 | Modified: Jul 11, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

libpng 1.2.5 and earlier does not properly calculate certain buffer offsets, which could allow remote attackers to execute arbitrary code via a buffer overflow attack.

Affected Software

Name Vendor Start Version End Version
Libpng3 Greg_roelofs 1.2.0 1.2.0
Libpng3 Greg_roelofs 1.2.1 1.2.1
Libpng3 Greg_roelofs 1.2.2 1.2.2
Libpng3 Greg_roelofs 1.2.3 1.2.3
Libpng3 Greg_roelofs 1.2.4 1.2.4
Libpng3 Greg_roelofs 1.2.5 1.2.5
Libpng Ubuntu dapper *
Libpng Ubuntu devel *
Libpng Ubuntu edgy *
Libpng Ubuntu feisty *
Libpng3 Ubuntu dapper *
Libpng3 Ubuntu edgy *

References