CVE Vulnerabilities

CVE-2004-0891

Published: Jan 27, 2005 | Modified: Oct 11, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
10 HIGH
AV:N/AC:L/Au:N/C:C/I:C/A:C
RedHat/V2
RedHat/V3
Ubuntu

Buffer overflow in the MSN protocol handler for gaim 0.79 to 1.0.1 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via an unexpected sequence of MSNSLP messages that results in an unbounded copy operation that writes to the wrong buffer.

Affected Software

Name Vendor Start Version End Version
Gaim Rob_flynn 0.10 0.10
Gaim Rob_flynn 0.10.3 0.10.3
Gaim Rob_flynn 0.50 0.50
Gaim Rob_flynn 0.51 0.51
Gaim Rob_flynn 0.52 0.52
Gaim Rob_flynn 0.53 0.53
Gaim Rob_flynn 0.54 0.54
Gaim Rob_flynn 0.55 0.55
Gaim Rob_flynn 0.56 0.56
Gaim Rob_flynn 0.57 0.57
Gaim Rob_flynn 0.58 0.58
Gaim Rob_flynn 0.59 0.59
Gaim Rob_flynn 0.59.1 0.59.1
Gaim Rob_flynn 0.60 0.60
Gaim Rob_flynn 0.61 0.61
Gaim Rob_flynn 0.62 0.62
Gaim Rob_flynn 0.63 0.63
Gaim Rob_flynn 0.64 0.64
Gaim Rob_flynn 0.65 0.65
Gaim Rob_flynn 0.66 0.66
Gaim Rob_flynn 0.67 0.67
Gaim Rob_flynn 0.68 0.68
Gaim Rob_flynn 0.69 0.69
Gaim Rob_flynn 0.70 0.70
Gaim Rob_flynn 0.71 0.71
Gaim Rob_flynn 0.72 0.72
Gaim Rob_flynn 0.73 0.73
Gaim Rob_flynn 0.74 0.74
Gaim Rob_flynn 0.75 0.75
Gaim Rob_flynn 0.78 0.78
Gaim Rob_flynn 0.82 0.82
Gaim Rob_flynn 0.82.1 0.82.1
Gaim Rob_flynn 1.0 1.0
Gaim Rob_flynn 1.0.1 1.0.1
Red Hat Enterprise Linux 3 RedHat gaim *
Gaim Ubuntu dapper *
Gaim Ubuntu edgy *
Gaim Ubuntu feisty *

References