CVE Vulnerabilities

CVE-2004-1145

Published: Dec 15, 2004 | Modified: Oct 11, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
5 MEDIUM
AV:N/AC:L/Au:N/C:N/I:P/A:N
RedHat/V2
RedHat/V3
Ubuntu

Multiple vulnerabilities in Konqueror in KDE 3.3.1 and earlier (1) allow access to restricted Java classes via JavaScript and (2) do not properly restrict access to certain Java classes from the Java applet, which allows remote attackers to bypass sandbox restrictions and read or write arbitrary files.

Affected Software

Name Vendor Start Version End Version
Ethereal Ethereal_group 0.9 0.9
Ethereal Ethereal_group 0.9.1 0.9.1
Ethereal Ethereal_group 0.9.2 0.9.2
Ethereal Ethereal_group 0.9.3 0.9.3
Ethereal Ethereal_group 0.9.4 0.9.4
Ethereal Ethereal_group 0.9.5 0.9.5
Ethereal Ethereal_group 0.9.6 0.9.6
Ethereal Ethereal_group 0.9.7 0.9.7
Ethereal Ethereal_group 0.9.8 0.9.8
Ethereal Ethereal_group 0.9.9 0.9.9
Ethereal Ethereal_group 0.9.10 0.9.10
Ethereal Ethereal_group 0.9.11 0.9.11
Ethereal Ethereal_group 0.9.12 0.9.12
Ethereal Ethereal_group 0.9.13 0.9.13
Ethereal Ethereal_group 0.9.14 0.9.14
Ethereal Ethereal_group 0.9.15 0.9.15
Ethereal Ethereal_group 0.9.16 0.9.16
Ethereal Ethereal_group 0.10 0.10
Ethereal Ethereal_group 0.10.1 0.10.1
Ethereal Ethereal_group 0.10.2 0.10.2
Ethereal Ethereal_group 0.10.3 0.10.3
Ethereal Ethereal_group 0.10.4 0.10.4
Ethereal Ethereal_group 0.10.5 0.10.5
Ethereal Ethereal_group 0.10.6 0.10.6
Ethereal Ethereal_group 0.10.7 0.10.7
Propack Sgi 3.0 3.0
Linux Conectiva 9.0 9.0
Linux Conectiva 10.0 10.0
Red Hat Enterprise Linux 4 RedHat kdelibs-6:3.3.1-3.3 *
Kdelibs Ubuntu dapper *
Kdelibs Ubuntu devel *
Kdelibs Ubuntu edgy *
Kdelibs Ubuntu feisty *

References