CVE Vulnerabilities

CVE-2004-1315

Published: Nov 12, 2004 | Modified: Jul 11, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

viewtopic.php in phpBB 2.x before 2.0.11 improperly URL decodes the highlight parameter when extracting words and phrases to highlight, which allows remote attackers to execute arbitrary PHP code by double-encoding the highlight value so that special characters are inserted into the result, which is then processed by PHP exec, as exploited by the Santy.A worm.

Affected Software

Name Vendor Start Version End Version
Phpbb Phpbb_group * *
Phpbb Phpbb_group 1.0.0 1.0.0
Phpbb Phpbb_group 1.0.1 1.0.1
Phpbb Phpbb_group 1.2.0 1.2.0
Phpbb Phpbb_group 1.2.1 1.2.1
Phpbb Phpbb_group 1.4.0 1.4.0
Phpbb Phpbb_group 1.4.1 1.4.1
Phpbb Phpbb_group 1.4.2 1.4.2
Phpbb Phpbb_group 1.4.4 1.4.4
Phpbb Phpbb_group 2.0.0 2.0.0
Phpbb Phpbb_group 2.0.1 2.0.1
Phpbb Phpbb_group 2.0.2 2.0.2
Phpbb Phpbb_group 2.0.3 2.0.3
Phpbb Phpbb_group 2.0.4 2.0.4
Phpbb Phpbb_group 2.0.5 2.0.5
Phpbb Phpbb_group 2.0.6 2.0.6
Phpbb Phpbb_group 2.0.6c 2.0.6c
Phpbb Phpbb_group 2.0.6d 2.0.6d
Phpbb Phpbb_group 2.0.7 2.0.7
Phpbb Phpbb_group 2.0.7a 2.0.7a
Phpbb Phpbb_group 2.0.8 2.0.8
Phpbb Phpbb_group 2.0.8a 2.0.8a
Phpbb Phpbb_group 2.0.9 2.0.9
Phpbb Phpbb_group 2.0.10 2.0.10
Phpbb Phpbb_group 2.0_beta1 2.0_beta1
Phpbb Phpbb_group 2.0_rc1 2.0_rc1
Phpbb Phpbb_group 2.0_rc2 2.0_rc2
Phpbb Phpbb_group 2.0_rc3 2.0_rc3
Phpbb Phpbb_group 2.0_rc4 2.0_rc4

References