CVE Vulnerabilities

CVE-2004-2299

Published: Dec 31, 2004 | Modified: Jul 11, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

Buffer overflow in Omnicron OmniHTTPd 3.0a and earlier allows remote attackers to execute arbitrary code via an HTTP GET request with a long Range header.

Affected Software

Name Vendor Start Version End Version
Omnihttpd Omnicron 1.1 1.1
Omnihttpd Omnicron 2.0.4 2.0.4
Omnihttpd Omnicron 2.0.5 2.0.5
Omnihttpd Omnicron 2.0.6 2.0.6
Omnihttpd Omnicron 2.0.7 2.0.7
Omnihttpd Omnicron 2.0.8 2.0.8
Omnihttpd Omnicron 2.0_9 2.0_9
Omnihttpd Omnicron 2.0_alpha_1 2.0_alpha_1
Omnihttpd Omnicron 2.0_alpha_2 2.0_alpha_2
Omnihttpd Omnicron 2.4_pro 2.4_pro
Omnihttpd Omnicron 2.10 2.10
Omnihttpd Omnicron 3.0a 3.0a

References