CVE Vulnerabilities

CVE-2004-2552

Published: Dec 31, 2004 | Modified: Jul 11, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
4.6 MEDIUM
AV:L/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

Buffer overflow in XBoard 4.2.7 and earlier might allow local users to execute arbitrary code via a long -icshost command line argument. NOTE: since the program is not setuid and not normally called from remote programs, there may not be a typical attack vector for the issue that crosses privilege boundaries. Therefore this may not be a vulnerability.

Affected Software

Name Vendor Start Version End Version
Xboard Tim_mann 4.2.1 4.2.1
Xboard Tim_mann 4.2.2 4.2.2
Xboard Tim_mann 4.2.3 4.2.3
Xboard Tim_mann 4.2.4 4.2.4
Xboard Tim_mann 4.2.5 4.2.5
Xboard Tim_mann 4.2.6 4.2.6
Xboard Tim_mann 4.2.7 4.2.7
Xboard Ubuntu dapper *
Xboard Ubuntu devel *
Xboard Ubuntu edgy *
Xboard Ubuntu feisty *
Xboard Ubuntu gutsy *

References