CVE Vulnerabilities

CVE-2005-1194

Published: May 04, 2005 | Modified: Oct 11, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
4.6 MEDIUM
AV:L/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

Stack-based buffer overflow in the ieee_putascii function for nasm 0.98 and earlier allows attackers to execute arbitrary code via a crafted asm file, a different vulnerability than CVE-2004-1287.

Affected Software

Name Vendor Start Version End Version
Enterprise_linux Redhat 2.1 2.1
Enterprise_linux Redhat 2.1 2.1
Enterprise_linux Redhat 2.1 2.1
Enterprise_linux Redhat 3.0 3.0
Enterprise_linux Redhat 3.0 3.0
Enterprise_linux Redhat 3.0 3.0
Enterprise_linux Redhat 4.0 4.0
Enterprise_linux Redhat 4.0 4.0
Enterprise_linux Redhat 4.0 4.0
Enterprise_linux_desktop Redhat 3.0 3.0
Enterprise_linux_desktop Redhat 4.0 4.0
Linux_advanced_workstation Redhat 2.1 2.1
Red Hat Enterprise Linux 3 RedHat nasm-0:0.98.35-3.EL3 *
Red Hat Enterprise Linux 4 RedHat nasm-0:0.98.38-3.EL4 *
Nasm Ubuntu dapper *
Nasm Ubuntu devel *
Nasm Ubuntu edgy *
Nasm Ubuntu feisty *

References