CVE Vulnerabilities

CVE-2005-3962

Published: Dec 01, 2005 | Modified: Oct 19, 2018
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
4.6 MEDIUM
AV:L/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

Integer overflow in the format string functionality (Perl_sv_vcatpvfn) in Perl 5.9.2 and 5.8.6 Perl allows attackers to overwrite arbitrary memory and possibly execute arbitrary code via format string specifiers with large values, which causes an integer wrap and leads to a buffer overflow, as demonstrated using format string vulnerabilities in Perl applications.

Affected Software

Name Vendor Start Version End Version
Perl Perl 5.8.6 5.8.6
Perl Perl 5.9.2 5.9.2
Red Hat Enterprise Linux 3 RedHat perl-2:5.8.0-90.4 *
Red Hat Enterprise Linux 4 RedHat perl-3:5.8.5-24.RHEL4 *
Perl Ubuntu dapper *
Perl Ubuntu devel *
Perl Ubuntu edgy *
Perl Ubuntu feisty *

References