CVE Vulnerabilities

CVE-2007-0233

Published: Jan 13, 2007 | Modified: Oct 19, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

wp-trackback.php in WordPress 2.0.6 and earlier does not properly unset variables when the input data includes a numeric parameter with a value matching an alphanumeric parameters hash value, which allows remote attackers to execute arbitrary SQL commands via the tb_id parameter. NOTE: it could be argued that this vulnerability is due to a bug in the unset PHP command (CVE-2006-3017) and the proper fix should be in PHP; if so, then this should not be treated as a vulnerability in WordPress.

Affected Software

Name Vendor Start Version End Version
Wordpress Wordpress 2.0 2.0
Wordpress Wordpress 2.0.2 2.0.2
Wordpress Wordpress 2.0.6 2.0.6
Wordpress Wordpress 2.0.1 2.0.1
Wordpress Wordpress 2.0.4 2.0.4
Wordpress Wordpress 0.6.2.1 0.6.2.1
Wordpress Wordpress 1.2.1 1.2.1
Wordpress Wordpress 0.7 0.7
Wordpress Wordpress 0.71 0.71
Wordpress Wordpress 2.0.5 2.0.5
Wordpress Wordpress 1.5.2 1.5.2
Wordpress Wordpress 2.0.3 2.0.3
Wordpress Wordpress 1.5.1.2 1.5.1.2
Wordpress Wordpress 1.2 1.2
Wordpress Wordpress 1.2.2 1.2.2
Wordpress Wordpress 1.5 1.5
Wordpress Wordpress 1.5.1 1.5.1
Wordpress Wordpress 0.6.2 0.6.2
Wordpress Wordpress 1.5.1.3 1.5.1.3

References