CVE Vulnerabilities

CVE-2007-1056

Published: Feb 21, 2007 | Modified: Oct 16, 2018
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.2 HIGH
AV:L/AC:L/Au:N/C:C/I:C/A:C
RedHat/V2
RedHat/V3
Ubuntu

VMware Workstation 5.5.3 build 34685 does not provide per-user restrictions on certain privileged actions, which allows local users to perform restricted operations such as changing system time, accessing hardware components, and stopping the VMware tools service service. NOTE: exploitation is simplified via (1) weak file permissions (Users = Read & Execute) for %PROGRAMFILES%VMware; and weak registry key permissions (access by Users) for (2) vmmouse, (3) vmscsi, (4) VMTools, (5) vmx_svga, and (6) vmxnet in HKLMSYSTEMCurrentControlSetServices; which allows local users to perform various privileged actions outside of the guest OS by executing certain files under %PROGRAMFILES%VMwareVMware Tools, as demonstrated by (a) VMControlPanel.cpl and (b) vmwareservice.exe.

Affected Software

Name Vendor Start Version End Version
Workstation Vmware 5.5.3_build_34685 5.5.3_build_34685

References