CVE Vulnerabilities

CVE-2007-1661

Published: Nov 07, 2007 | Modified: Oct 16, 2018
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
6.4 MEDIUM
AV:N/AC:L/Au:N/C:P/I:N/A:P
RedHat/V2
RedHat/V3
Ubuntu

Perl-Compatible Regular Expression (PCRE) library before 7.3 backtracks too far when matching certain input bytes against some regex patterns in non-UTF-8 mode, which allows context-dependent attackers to obtain sensitive information or cause a denial of service (crash), as demonstrated by the X?d and P{L}?d patterns.

Affected Software

Name Vendor Start Version End Version
Perl-compatible_regular_expression_library Pcre 7.0 7.0
Perl-compatible_regular_expression_library Pcre 7.1 7.1
Perl-compatible_regular_expression_library Pcre * 7.2

References