CVE Vulnerabilities

CVE-2007-4680

Improper Authentication

Published: Nov 15, 2007 | Modified: Jul 29, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
6.8 MEDIUM
AV:N/AC:M/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

CFNetwork in Apple Mac OS X 10.3.9 and 10.4 through 10.4.10 does not properly validate certificates, which allows remote attackers to spoof trusted SSL certificates via a man-in-the-middle attack.

Weakness

When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.

Affected Software

Name Vendor Start Version End Version
Mac_os_x Apple 10.4.3 10.4.3
Mac_os_x_server Apple 10.4.3 10.4.3
Mac_os_x_server Apple 10.4.10 10.4.10
Mac_os_x_server Apple 10.4.9 10.4.9
Mac_os_x Apple 10.4.1 10.4.1
Mac_os_x_server Apple 10.4.2 10.4.2
Mac_os_x_server Apple 10.4.4 10.4.4
Mac_os_x_server Apple 10.4.1 10.4.1
Mac_os_x Apple 10.4.9 10.4.9
Mac_os_x Apple 10.4.7 10.4.7
Mac_os_x Apple 10.4.4 10.4.4
Mac_os_x_server Apple 10.4 10.4
Mac_os_x_server Apple 10.4.5 10.4.5
Mac_os_x Apple 10.4 10.4
Mac_os_x_server Apple 10.4.6 10.4.6
Mac_os_x_server Apple 10.3.9 10.3.9
Mac_os_x_server Apple 10.4.8 10.4.8
Mac_os_x Apple 10.4.6 10.4.6
Mac_os_x Apple 10.4.5 10.4.5
Mac_os_x Apple 10.3.9 10.3.9
Mac_os_x Apple 10.4.8 10.4.8
Mac_os_x Apple * 10.4.10
Mac_os_x_server Apple 10.4.7 10.4.7
Mac_os_x Apple 10.4.2 10.4.2

Potential Mitigations

References