CVE Vulnerabilities

CVE-2007-4769

Published: Jan 09, 2008 | Modified: Oct 15, 2018
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
6.8 MEDIUM
AV:N/AC:L/Au:S/C:N/I:N/A:C
RedHat/V2
RedHat/V3
Ubuntu

The regular expression parser in TCL before 8.4.17, as used in PostgreSQL 8.2 before 8.2.6, 8.1 before 8.1.11, 8.0 before 8.0.15, and 7.4 before 7.4.19, allows remote authenticated users to cause a denial of service (backend crash) via an out-of-bounds backref number.

Affected Software

Name Vendor Start Version End Version
Postgresql Postgresql 7.3 (including) 7.3 (including)
Postgresql Postgresql 7.3.1 (including) 7.3.1 (including)
Postgresql Postgresql 7.3.2 (including) 7.3.2 (including)
Postgresql Postgresql 7.3.3 (including) 7.3.3 (including)
Postgresql Postgresql 7.3.4 (including) 7.3.4 (including)
Postgresql Postgresql 7.3.6 (including) 7.3.6 (including)
Postgresql Postgresql 7.3.8 (including) 7.3.8 (including)
Postgresql Postgresql 7.3.9 (including) 7.3.9 (including)
Postgresql Postgresql 7.3.10 (including) 7.3.10 (including)
Postgresql Postgresql 7.3.11 (including) 7.3.11 (including)
Postgresql Postgresql 7.3.12 (including) 7.3.12 (including)
Postgresql Postgresql 7.3.13 (including) 7.3.13 (including)
Postgresql Postgresql 7.3.14 (including) 7.3.14 (including)
Postgresql Postgresql 7.3.15 (including) 7.3.15 (including)
Postgresql Postgresql 7.3.16 (including) 7.3.16 (including)
Postgresql Postgresql 7.3.19 (including) 7.3.19 (including)
Postgresql Postgresql 7.4 (including) 7.4 (including)
Postgresql Postgresql 7.4.1 (including) 7.4.1 (including)
Postgresql Postgresql 7.4.2 (including) 7.4.2 (including)
Postgresql Postgresql 7.4.3 (including) 7.4.3 (including)
Postgresql Postgresql 7.4.4 (including) 7.4.4 (including)
Postgresql Postgresql 7.4.5 (including) 7.4.5 (including)
Postgresql Postgresql 7.4.6 (including) 7.4.6 (including)
Postgresql Postgresql 7.4.7 (including) 7.4.7 (including)
Postgresql Postgresql 7.4.8 (including) 7.4.8 (including)
Postgresql Postgresql 7.4.9 (including) 7.4.9 (including)
Postgresql Postgresql 7.4.10 (including) 7.4.10 (including)
Postgresql Postgresql 7.4.11 (including) 7.4.11 (including)
Postgresql Postgresql 7.4.12 (including) 7.4.12 (including)
Postgresql Postgresql 7.4.13 (including) 7.4.13 (including)
Postgresql Postgresql 7.4.14 (including) 7.4.14 (including)
Postgresql Postgresql 7.4.16 (including) 7.4.16 (including)
Postgresql Postgresql 7.4.17 (including) 7.4.17 (including)
Postgresql Postgresql 8.0 (including) 8.0 (including)
Postgresql Postgresql 8.0.1 (including) 8.0.1 (including)
Postgresql Postgresql 8.0.2 (including) 8.0.2 (including)
Postgresql Postgresql 8.0.3 (including) 8.0.3 (including)
Postgresql Postgresql 8.0.4 (including) 8.0.4 (including)
Postgresql Postgresql 8.0.5 (including) 8.0.5 (including)
Postgresql Postgresql 8.0.7 (including) 8.0.7 (including)
Postgresql Postgresql 8.0.8 (including) 8.0.8 (including)
Postgresql Postgresql 8.0.9 (including) 8.0.9 (including)
Postgresql Postgresql 8.0.11 (including) 8.0.11 (including)
Postgresql Postgresql 8.0.13 (including) 8.0.13 (including)
Postgresql Postgresql 8.0.317 (including) 8.0.317 (including)
Postgresql Postgresql 8.1.1 (including) 8.1.1 (including)
Postgresql Postgresql 8.1.3 (including) 8.1.3 (including)
Postgresql Postgresql 8.1.4 (including) 8.1.4 (including)
Postgresql Postgresql 8.1.5 (including) 8.1.5 (including)
Postgresql Postgresql 8.1.7 (including) 8.1.7 (including)
Postgresql Postgresql 8.1.8 (including) 8.1.8 (including)
Postgresql Postgresql 8.1.9 (including) 8.1.9 (including)
Postgresql Postgresql 8.2 (including) 8.2 (including)
Postgresql Postgresql 8.2.2 (including) 8.2.2 (including)
Postgresql Postgresql 8.2.3 (including) 8.2.3 (including)
Postgresql Postgresql 8.2.4 (including) 8.2.4 (including)
Tcl_tk Tcl_tk * 8.4.16 (including)

References