CVE Vulnerabilities

CVE-2007-6067

Published: Jan 09, 2008 | Modified: Oct 15, 2018
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
6.8 MEDIUM
AV:N/AC:L/Au:S/C:N/I:N/A:C
RedHat/V2
RedHat/V3
Ubuntu

Algorithmic complexity vulnerability in the regular expression parser in TCL before 8.4.17, as used in PostgreSQL 8.2 before 8.2.6, 8.1 before 8.1.11, 8.0 before 8.0.15, and 7.4 before 7.4.19, allows remote authenticated users to cause a denial of service (memory consumption) via a crafted complex regular expression with doubly-nested states.

Affected Software

Name Vendor Start Version End Version
Postgresql Postgresql 7.4.16 7.4.16
Postgresql Postgresql 8.0.7 8.0.7
Postgresql Postgresql 8.0.2 8.0.2
Postgresql Postgresql 8.1.7 8.1.7
Postgresql Postgresql 7.3.3 7.3.3
Tcl_tk Tcl_tk * 8.4.16
Postgresql Postgresql 8.2.4 8.2.4
Postgresql Postgresql 7.3 7.3
Postgresql Postgresql 8.0.9 8.0.9
Postgresql Postgresql 7.4.1 7.4.1
Postgresql Postgresql 7.3.9 7.3.9
Postgresql Postgresql 7.3.10 7.3.10
Postgresql Postgresql 8.2.2 8.2.2
Postgresql Postgresql 8.1.3 8.1.3
Postgresql Postgresql 7.4.14 7.4.14
Postgresql Postgresql 7.4.6 7.4.6
Postgresql Postgresql 7.4.11 7.4.11
Postgresql Postgresql 7.3.16 7.3.16
Postgresql Postgresql 8.0.3 8.0.3
Postgresql Postgresql 7.3.15 7.3.15
Postgresql Postgresql 7.4.7 7.4.7
Postgresql Postgresql 7.3.11 7.3.11
Postgresql Postgresql 8.1.9 8.1.9
Postgresql Postgresql 7.4.17 7.4.17
Postgresql Postgresql 7.4.3 7.4.3
Postgresql Postgresql 7.3.6 7.3.6
Postgresql Postgresql 7.4.9 7.4.9
Postgresql Postgresql 7.4.5 7.4.5
Postgresql Postgresql 7.3.8 7.3.8
Postgresql Postgresql 8.0.8 8.0.8
Postgresql Postgresql 7.4.8 7.4.8
Postgresql Postgresql 7.4 7.4
Postgresql Postgresql 7.4.4 7.4.4
Postgresql Postgresql 8.0.13 8.0.13
Postgresql Postgresql 7.3.13 7.3.13
Postgresql Postgresql 8.1.4 8.1.4
Postgresql Postgresql 8.0.1 8.0.1
Postgresql Postgresql 8.1.8 8.1.8
Postgresql Postgresql 7.3.2 7.3.2
Postgresql Postgresql 7.4.12 7.4.12
Postgresql Postgresql 7.3.12 7.3.12
Postgresql Postgresql 8.1.1 8.1.1
Postgresql Postgresql 8.1.5 8.1.5
Postgresql Postgresql 7.3.14 7.3.14
Postgresql Postgresql 7.3.1 7.3.1
Postgresql Postgresql 7.4.10 7.4.10
Postgresql Postgresql 8.2.3 8.2.3
Postgresql Postgresql 7.3.19 7.3.19
Postgresql Postgresql 8.0.4 8.0.4
Postgresql Postgresql 8.0.5 8.0.5
Postgresql Postgresql 8.2 8.2
Postgresql Postgresql 7.4.2 7.4.2
Postgresql Postgresql 8.0.11 8.0.11
Postgresql Postgresql 8.0.317 8.0.317
Postgresql Postgresql 8.0 8.0
Postgresql Postgresql 7.4.13 7.4.13
Postgresql Postgresql 7.3.4 7.3.4

References