CVE Vulnerabilities

CVE-2008-2376

Published: Jul 09, 2008 | Modified: Oct 11, 2018
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

Integer overflow in the rb_ary_fill function in array.c in Ruby before revision 17756 allows context-dependent attackers to cause a denial of service (crash) or possibly have unspecified other impact via a call to the Array#fill method with a start (aka beg) argument greater than ARY_MAX_SIZE. NOTE: this issue exists because of an incomplete fix for other closely related integer overflows.

Affected Software

Name Vendor Start Version End Version
Red Hat Enterprise Linux 2.1 RedHat ruby-0:1.6.4-6.el2 *
Red Hat Enterprise Linux 3 RedHat ruby-0:1.6.8-12.el3 *
Red Hat Enterprise Linux 4 RedHat ruby-0:1.8.1-7.el4_6.1 *
Red Hat Enterprise Linux 5 RedHat ruby-0:1.8.5-5.el5_2.3 *
Ruby1.8 Ubuntu dapper *
Ruby1.8 Ubuntu feisty *
Ruby1.8 Ubuntu gutsy *
Ruby1.8 Ubuntu hardy *
Ruby1.8 Ubuntu upstream *
Ruby1.9 Ubuntu dapper *
Ruby1.9 Ubuntu feisty *
Ruby1.9 Ubuntu gutsy *
Ruby1.9 Ubuntu hardy *
Ruby1.9 Ubuntu intrepid *
Ruby1.9 Ubuntu jaunty *
Ruby1.9 Ubuntu karmic *
Ruby1.9 Ubuntu lucid *
Ruby1.9 Ubuntu upstream *

References