CVE Vulnerabilities

CVE-2008-4126

Published: Sep 18, 2008 | Modified: Sep 19, 2008
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
6.4 MEDIUM
AV:N/AC:L/Au:N/C:N/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

PyDNS (aka python-dns) before 2.3.1-5 in Debian GNU/Linux does not use random source ports for DNS requests and does not use random transaction IDs for DNS retries, which makes it easier for remote attackers to spoof DNS responses, a different vulnerability than CVE-2008-1447. NOTE: this vulnerability exists because of an incomplete fix for CVE-2008-4099.

Affected Software

Name Vendor Start Version End Version
Python-dns Ubuntu dapper *
Python-dns Ubuntu devel *
Python-dns Ubuntu feisty *
Python-dns Ubuntu gutsy *
Python-dns Ubuntu hardy *
Python-dns Ubuntu upstream *

References