CVE Vulnerabilities

CVE-2008-6540

Published: Mar 30, 2009 | Modified: Oct 11, 2018
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
5.1 MEDIUM
AV:N/AC:H/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

DotNetNuke before 4.8.2, during installation or upgrade, does not warn the administrator when the default (1) ValidationKey and (2) DecryptionKey values cannot be modified in the web.config file, which allows remote attackers to bypass intended access restrictions by using the default keys.

Affected Software

Name Vendor Start Version End Version
Dotnetnuke Dotnetnuke 1.0.6 1.0.6
Dotnetnuke Dotnetnuke 1.0.7 1.0.7
Dotnetnuke Dotnetnuke 1.0.8 1.0.8
Dotnetnuke Dotnetnuke 1.0.9 1.0.9
Dotnetnuke Dotnetnuke 1.0.10d 1.0.10d
Dotnetnuke Dotnetnuke 1.0.10e 1.0.10e
Dotnetnuke Dotnetnuke 2.1.1 2.1.1
Dotnetnuke Dotnetnuke 2.1.2 2.1.2
Dotnetnuke Dotnetnuke 3.0.7 3.0.7
Dotnetnuke Dotnetnuke 3.0.8 3.0.8
Dotnetnuke Dotnetnuke 3.0.11 3.0.11
Dotnetnuke Dotnetnuke 3.1.0 3.1.0
Dotnetnuke Dotnetnuke 3.3.5 3.3.5
Dotnetnuke Dotnetnuke 4.0 4.0
Dotnetnuke Dotnetnuke 4.3.5 4.3.5
Dotnetnuke Dotnetnuke 4.5.2 4.5.2
Dotnetnuke Dotnetnuke * 4.8.1

References