CVE Vulnerabilities

CVE-2009-2067

Improper Authentication

Published: Jun 15, 2009 | Modified: Oct 30, 2018
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
6.8 MEDIUM
AV:N/AC:M/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

Opera detects http content in https web pages only when the top-level frame uses https, which allows man-in-the-middle attackers to execute arbitrary web script, in an https site’s context, by modifying an http page to include an https iframe that references a script file on an http site, related to HTTP-Intended-but-HTTPS-Loadable (HPIHSL) pages.

Weakness

When an actor claims to have a given identity, the software does not prove or insufficiently proves that the claim is correct.

Affected Software

Name Vendor Start Version End Version
Opera_browser Opera 7.0 7.0
Opera_browser Opera 7.23 7.23
Opera_browser Opera 7.53 7.53
Opera_browser Opera 7.54 7.54
Opera_browser Opera 7.60 7.60
Opera_browser Opera 8.0 8.0
Opera_browser Opera 8.01 8.01
Opera_browser Opera 8.02 8.02
Opera_browser Opera 8.50 8.50
Opera_browser Opera 8.51 8.51
Opera_browser Opera 8.52 8.52
Opera_browser Opera 8.53 8.53
Opera_browser Opera 8.54 8.54
Opera_browser Opera 9.0 9.0
Opera_browser Opera 9.01 9.01
Opera_browser Opera 9.02 9.02
Opera_browser Opera 9.10 9.10
Opera_browser Opera 9.12 9.12
Opera_browser Opera 9.20 9.20
Opera_browser Opera 9.21 9.21
Opera_browser Opera * 9.22

Potential Mitigations

References