CVE Vulnerabilities

CVE-2009-3616

Published: Oct 23, 2009 | Modified: Nov 02, 2020
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
8.5 HIGH
AV:N/AC:M/Au:S/C:C/I:C/A:C
RedHat/V2
RedHat/V3
Ubuntu

Multiple use-after-free vulnerabilities in vnc.c in the VNC server in QEMU 0.10.6 and earlier might allow guest OS users to execute arbitrary code on the host OS by establishing a connection from a VNC client and then (1) disconnecting during data transfer, (2) sending a message using incorrect integer data types, or (3) using the Fuzzy Screen Mode protocol, related to double free vulnerabilities.

Affected Software

Name Vendor Start Version End Version
Qemu Qemu 0.1.0 0.1.0
Qemu Qemu 0.1.1 0.1.1
Qemu Qemu 0.1.2 0.1.2
Qemu Qemu 0.1.3 0.1.3
Qemu Qemu 0.1.4 0.1.4
Qemu Qemu 0.1.5 0.1.5
Qemu Qemu 0.1.6 0.1.6
Qemu Qemu 0.2.0 0.2.0
Qemu Qemu 0.3.0 0.3.0
Qemu Qemu 0.4.0 0.4.0
Qemu Qemu 0.4.1 0.4.1
Qemu Qemu 0.4.2 0.4.2
Qemu Qemu 0.4.3 0.4.3
Qemu Qemu 0.5.0 0.5.0
Qemu Qemu 0.5.1 0.5.1
Qemu Qemu 0.5.2 0.5.2
Qemu Qemu 0.5.3 0.5.3
Qemu Qemu 0.5.4 0.5.4
Qemu Qemu 0.5.5 0.5.5
Qemu Qemu 0.6.0 0.6.0
Qemu Qemu 0.6.1 0.6.1
Qemu Qemu 0.7.0 0.7.0
Qemu Qemu 0.7.1 0.7.1
Qemu Qemu 0.7.2 0.7.2
Qemu Qemu 0.8.0 0.8.0
Qemu Qemu 0.8.1 0.8.1
Qemu Qemu 0.8.2 0.8.2
Qemu Qemu 0.9.0 0.9.0
Qemu Qemu 0.9.1 0.9.1
Qemu Qemu 0.10.0 0.10.0
Qemu Qemu 0.10.1 0.10.1
Qemu Qemu 0.10.2 0.10.2
Qemu Qemu 0.10.3 0.10.3
Qemu Qemu 0.10.4 0.10.4
Qemu Qemu 0.10.5 0.10.5
Qemu Qemu * 0.10.6
Qemu Ubuntu jaunty *
Qemu Ubuntu upstream *
Qemu-kvm Ubuntu upstream *

References