CVE Vulnerabilities

CVE-2009-4299

Published: Dec 16, 2009 | Modified: Dec 01, 2020
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
5 MEDIUM
AV:N/AC:L/Au:N/C:P/I:N/A:N
RedHat/V2
RedHat/V3
Ubuntu

mod/glossary/showentry.php in the Glossary module for Moodle 1.8 before 1.8.11 and 1.9 before 1.9.7 does not properly perform access control, which allows attackers to read unauthorized Glossary entries via unknown vectors.

Affected Software

Name Vendor Start Version End Version
Moodle Moodle 1.8.1 1.8.1
Moodle Moodle 1.8.2 1.8.2
Moodle Moodle 1.8.3 1.8.3
Moodle Moodle 1.8.4 1.8.4
Moodle Moodle 1.8.5 1.8.5
Moodle Moodle 1.8.7 1.8.7
Moodle Moodle 1.8.8 1.8.8
Moodle Moodle 1.8.9 1.8.9
Moodle Moodle 1.8.10 1.8.10
Moodle Moodle 1.9.1 1.9.1
Moodle Moodle 1.9.2 1.9.2
Moodle Moodle 1.9.3 1.9.3
Moodle Moodle 1.9.4 1.9.4
Moodle Moodle 1.9.5 1.9.5
Moodle Moodle 1.9.6 1.9.6
Moodle Ubuntu dapper *
Moodle Ubuntu hardy *
Moodle Ubuntu intrepid *
Moodle Ubuntu jaunty *
Moodle Ubuntu karmic *
Moodle Ubuntu lucid *
Moodle Ubuntu maverick *

References