CVE Vulnerabilities

CVE-2010-1815

Published: Sep 09, 2010 | Modified: Nov 16, 2018
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
6.8 MEDIUM
AV:N/AC:M/Au:N/C:P/I:P/A:P
RedHat/V2
3.7 MODERATE
AV:L/AC:H/Au:N/C:P/I:P/A:P
RedHat/V3
Ubuntu

Use-after-free vulnerability in WebKit in Apple iOS before 4.1 on the iPhone and iPod touch, and webkitgtk before 1.2.6, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via vectors involving scrollbars.

Affected Software

Name Vendor Start Version End Version
Red Hat Enterprise Linux 6 RedHat webkitgtk-0:1.2.6-2.el6_0 *
Qt4-x11 Ubuntu jaunty *
Qt4-x11 Ubuntu karmic *
Qt4-x11 Ubuntu lucid *
Webkit Ubuntu hardy *
Webkit Ubuntu jaunty *
Webkit Ubuntu karmic *
Webkit Ubuntu lucid *
Webkit Ubuntu maverick *
Webkit Ubuntu upstream *

References