CVE Vulnerabilities

CVE-2010-1830

Published: Nov 15, 2010 | Modified: Dec 10, 2010
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
5 MEDIUM
AV:N/AC:L/Au:N/C:P/I:N/A:N
RedHat/V2
RedHat/V3
Ubuntu

AFP Server in Apple Mac OS X 10.5.8 and 10.6.x before 10.6.5 generates different error messages depending on whether a share exists, which allows remote attackers to enumerate valid share names via unspecified vectors.

Affected Software

Name Vendor Start Version End Version
Mac_os_x Apple 10.5.8 10.5.8
Mac_os_x Apple 10.6.0 10.6.0
Mac_os_x Apple 10.6.1 10.6.1
Mac_os_x Apple 10.6.2 10.6.2
Mac_os_x Apple 10.6.3 10.6.3
Mac_os_x Apple 10.6.4 10.6.4

References