CVE Vulnerabilities

CVE-2010-3430

Published: Jan 24, 2011 | Modified: Jan 03, 2019
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
4.7 MEDIUM
AV:L/AC:M/Au:N/C:C/I:N/A:N
RedHat/V2
1.9 MODERATE
AV:L/AC:M/Au:N/C:P/I:N/A:N
RedHat/V3
Ubuntu

The privilege-dropping implementation in the (1) pam_env and (2) pam_mail modules in Linux-PAM (aka pam) 1.1.2 does not perform the required setfsgid and setgroups system calls, which might allow local users to obtain sensitive information by leveraging unintended group permissions, as demonstrated by a symlink attack on the .pam_environment file in a user’s home directory. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-3435.

Affected Software

Name Vendor Start Version End Version
Linux-pam Linux-pam 1.1.2 1.1.2
Pam Ubuntu dapper *
Pam Ubuntu devel *
Pam Ubuntu hardy *
Pam Ubuntu karmic *
Pam Ubuntu lucid *
Pam Ubuntu maverick *
Pam Ubuntu natty *
Pam Ubuntu upstream *

References