CVE Vulnerabilities

CVE-2011-2914

Published: Jun 07, 2012 | Modified: Aug 29, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
6.8 MEDIUM
AV:N/AC:M/Au:N/C:P/I:P/A:P
RedHat/V2
6.8 IMPORTANT
AV:N/AC:M/Au:N/C:P/I:P/A:P
RedHat/V3
Ubuntu

Off-by-one error in the CSoundFile::ReadDSM function in src/load_dms.cpp in libmodplug before 0.8.8.4 allows remote attackers to cause a denial of service (memory corruption) and possibly execute arbitrary code via a crafted DSM file with a large number of samples.

Affected Software

Name Vendor Start Version End Version
Libmodplug Konstanty_bialkowski 0.8 0.8
Libmodplug Konstanty_bialkowski 0.8.4 0.8.4
Libmodplug Konstanty_bialkowski 0.8.5 0.8.5
Libmodplug Konstanty_bialkowski 0.8.6 0.8.6
Libmodplug Konstanty_bialkowski 0.8.7 0.8.7
Libmodplug Konstanty_bialkowski 0.8.8 0.8.8
Libmodplug Konstanty_bialkowski 0.8.8.1 0.8.8.1
Libmodplug Konstanty_bialkowski 0.8.8.2 0.8.8.2
Libmodplug Konstanty_bialkowski * 0.8.8.3
Red Hat Enterprise Linux 4 RedHat gstreamer-plugins-0:0.8.5-1.EL.4 *
Gst-plugins-bad0.10 Ubuntu hardy *
Libmodplug Ubuntu hardy *
Libmodplug Ubuntu lucid *
Libmodplug Ubuntu maverick *
Libmodplug Ubuntu natty *
Libmodplug Ubuntu oneiric *
Libmodplug Ubuntu upstream *

References