CVE Vulnerabilities

CVE-2011-4211

Published: Oct 30, 2011 | Modified: Aug 29, 2017
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.2 HIGH
AV:L/AC:L/Au:N/C:C/I:C/A:C
RedHat/V2
RedHat/V3
Ubuntu

The FakeFile implementation in the sandbox environment in the Google App Engine Python SDK before 1.5.4 does not properly control the opening of files, which allows local users to bypass intended access restrictions and create arbitrary files via ALLOWED_MODES and ALLOWED_DIRS changes within the code parameter to _ah/admin/interactive/execute, a different vulnerability than CVE-2011-1364.

Affected Software

Name Vendor Start Version End Version
App_engine_python_sdk Google 1.4.3 1.4.3
App_engine_python_sdk Google 1.1.5 1.1.5
App_engine_python_sdk Google 1.3.4 1.3.4
App_engine_python_sdk Google 1.2.6 1.2.6
App_engine_python_sdk Google 1.2.2 1.2.2
App_engine_python_sdk Google 1.2.7 1.2.7
App_engine_python_sdk Google 1.1.7 1.1.7
App_engine_python_sdk Google 1.0.2 1.0.2
App_engine_python_sdk Google 1.1.3 1.1.3
App_engine_python_sdk Google 1.5.2 1.5.2
App_engine_python_sdk Google 1.1.0 1.1.0
App_engine_python_sdk Google 1.3.1 1.3.1
App_engine_python_sdk Google * 1.5.3
App_engine_python_sdk Google 1.0.1 1.0.1
App_engine_python_sdk Google 1.4.0 1.4.0
App_engine_python_sdk Google 1.1.2 1.1.2
App_engine_python_sdk Google 1.3.8 1.3.8
App_engine_python_sdk Google 1.3.3 1.3.3
App_engine_python_sdk Google 1.2.5 1.2.5
App_engine_python_sdk Google 1.2.0 1.2.0
App_engine_python_sdk Google 1.1.8 1.1.8
App_engine_python_sdk Google 1.1.9 1.1.9
App_engine_python_sdk Google 1.3.7 1.3.7
App_engine_python_sdk Google 1.3.2 1.3.2
App_engine_python_sdk Google 1.2.4 1.2.4
App_engine_python_sdk Google 1.2.1 1.2.1
App_engine_python_sdk Google 1.4.1 1.4.1
App_engine_python_sdk Google 1.2.3 1.2.3
App_engine_python_sdk Google 1.1.4 1.1.4
App_engine_python_sdk Google 1.5.1 1.5.1
App_engine_python_sdk Google 1.3.0 1.3.0
App_engine_python_sdk Google 1.3.6 1.3.6
App_engine_python_sdk Google 1.3.5 1.3.5
App_engine_python_sdk Google 1.1.1 1.1.1
App_engine_python_sdk Google 1.1.6 1.1.6
App_engine_python_sdk Google 1.5.0 1.5.0
App_engine_python_sdk Google 1.4.2 1.4.2

References