CVE Vulnerabilities

CVE-2011-4296

Published: Jul 16, 2012 | Modified: Feb 13, 2023
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
5.5 MEDIUM
AV:N/AC:L/Au:S/C:N/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

lib/db/access.php in Moodle 2.0.x before 2.0.4 and 2.1.x before 2.1.1 assigns incorrect capabilities to the course-creator role, which allows remote authenticated users to modify course filters by leveraging this role.

Affected Software

Name Vendor Start Version End Version
Moodle Moodle 2.0.2 2.0.2
Moodle Moodle 2.0.1 2.0.1
Moodle Moodle 2.0.3 2.0.3
Moodle Moodle 2.0.0 2.0.0
Moodle Moodle 2.1.0 2.1.0

References