CVE Vulnerabilities

CVE-2011-4356

Published: Dec 05, 2011 | Modified: Jan 03, 2012
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
6.9 MEDIUM
AV:L/AC:M/Au:N/C:C/I:C/A:C
RedHat/V2
RedHat/V3
Ubuntu

Celery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of the –uid and –gid arguments to celerybeat, celeryd_detach, celeryd-multi, and celeryev, which allows local users to gain privileges via vectors involving crafted code that is executed by the worker process.

Affected Software

Name Vendor Start Version End Version
Celery Celeryproject 2.2.0 2.2.0
Celery Celeryproject 2.3.2 2.3.2
Celery Celeryproject 2.3.0 2.3.0
Celery Celeryproject 2.2.7 2.2.7
Celery Celeryproject 2.2.2 2.2.2
Celery Celeryproject 2.2.4 2.2.4
Celery Celeryproject 2.4.2 2.4.2
Celery Celeryproject 2.1.0 2.1.0
Celery Celeryproject 2.2.1 2.2.1
Celery Celeryproject 2.2.5 2.2.5
Celery Celeryproject 2.2.6 2.2.6
Celery Celeryproject 2.4.0 2.4.0
Celery Celeryproject 2.4.3 2.4.3
Celery Celeryproject 2.4.1 2.4.1
Celery Celeryproject 2.3.3 2.3.3
Celery Celeryproject 2.2.3 2.2.3
Celery Celeryproject 2.3.1 2.3.1

References