CVE Vulnerabilities

CVE-2011-4899

Published: Jan 30, 2012 | Modified: Nov 07, 2023
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

wp-admin/setup-config.php in the installation component in WordPress 3.3.1 and earlier does not ensure that the specified MySQL database service is appropriate, which allows remote attackers to configure an arbitrary database via the dbhost and dbname parameters, and subsequently conduct static code injection and cross-site scripting (XSS) attacks via (1) an HTTP request or (2) a MySQL query. NOTE: the vendor disputes the significance of this issue; however, remote code execution makes the issue important in many realistic environments

Affected Software

Name Vendor Start Version End Version
Wordpress Wordpress * 3.3.1
Wordpress Wordpress 0.7 0.7
Wordpress Wordpress 0.71 0.71
Wordpress Wordpress 0.72 0.72
Wordpress Wordpress 0.711 0.711
Wordpress Wordpress 1.0 1.0
Wordpress Wordpress 1.0.1 1.0.1
Wordpress Wordpress 1.0.2 1.0.2
Wordpress Wordpress 1.2 1.2
Wordpress Wordpress 1.2.1 1.2.1
Wordpress Wordpress 1.2.2 1.2.2
Wordpress Wordpress 1.5 1.5
Wordpress Wordpress 1.5.1 1.5.1
Wordpress Wordpress 1.5.1.2 1.5.1.2
Wordpress Wordpress 1.5.1.3 1.5.1.3
Wordpress Wordpress 1.5.2 1.5.2
Wordpress Wordpress 2.0 2.0
Wordpress Wordpress 2.0.1 2.0.1
Wordpress Wordpress 2.0.2 2.0.2
Wordpress Wordpress 2.0.3 2.0.3
Wordpress Wordpress 2.0.4 2.0.4
Wordpress Wordpress 2.0.5 2.0.5
Wordpress Wordpress 2.0.6 2.0.6
Wordpress Wordpress 2.0.7 2.0.7
Wordpress Wordpress 2.0.8 2.0.8
Wordpress Wordpress 2.0.9 2.0.9
Wordpress Wordpress 2.0.10 2.0.10
Wordpress Wordpress 2.0.11 2.0.11
Wordpress Wordpress 2.1 2.1
Wordpress Wordpress 2.1.1 2.1.1
Wordpress Wordpress 2.1.2 2.1.2
Wordpress Wordpress 2.1.3 2.1.3
Wordpress Wordpress 2.2 2.2
Wordpress Wordpress 2.2.1 2.2.1
Wordpress Wordpress 2.2.2 2.2.2
Wordpress Wordpress 2.2.3 2.2.3
Wordpress Wordpress 2.3 2.3
Wordpress Wordpress 2.3.1 2.3.1
Wordpress Wordpress 2.3.2 2.3.2
Wordpress Wordpress 2.3.3 2.3.3
Wordpress Wordpress 2.5 2.5
Wordpress Wordpress 2.5.1 2.5.1
Wordpress Wordpress 2.6 2.6
Wordpress Wordpress 2.6.1 2.6.1
Wordpress Wordpress 2.6.2 2.6.2
Wordpress Wordpress 2.6.3 2.6.3
Wordpress Wordpress 2.6.5 2.6.5
Wordpress Wordpress 2.7 2.7
Wordpress Wordpress 2.7.1 2.7.1
Wordpress Wordpress 2.8 2.8
Wordpress Wordpress 2.8.1 2.8.1
Wordpress Wordpress 2.8.2 2.8.2
Wordpress Wordpress 2.8.3 2.8.3
Wordpress Wordpress 2.8.4 2.8.4
Wordpress Wordpress 2.8.5 2.8.5
Wordpress Wordpress 2.8.6 2.8.6
Wordpress Wordpress 2.9 2.9
Wordpress Wordpress 2.9.1 2.9.1
Wordpress Wordpress 2.9.2 2.9.2
Wordpress Wordpress 3.0 3.0
Wordpress Wordpress 3.0.1 3.0.1
Wordpress Wordpress 3.0.2 3.0.2
Wordpress Wordpress 3.0.3 3.0.3
Wordpress Wordpress 3.0.4 3.0.4
Wordpress Wordpress 3.0.5 3.0.5
Wordpress Wordpress 3.0.6 3.0.6
Wordpress Wordpress 3.1 3.1
Wordpress Wordpress 3.1.1 3.1.1
Wordpress Wordpress 3.1.2 3.1.2
Wordpress Wordpress 3.1.3 3.1.3
Wordpress Wordpress 3.1.4 3.1.4
Wordpress Wordpress 3.2.1 3.2.1
Wordpress Wordpress 3.3 3.3

References