CVE Vulnerabilities

CVE-2012-4442

Published: Oct 05, 2012 | Modified: Mar 26, 2020
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
4.7 MEDIUM
AV:L/AC:M/Au:N/C:C/I:N/A:N
RedHat/V2
RedHat/V3
Ubuntu

Monkey HTTP Daemon 0.9.3 retains the supplementary group IDs of the root account during operations with a non-root effective UID, which might allow local users to bypass intended file-read restrictions by leveraging a race condition in a file-permission check.

Affected Software

Name Vendor Start Version End Version
Monkey Monkey-project 0.9.3 0.9.3
Monkey Ubuntu lucid *
Monkey Ubuntu natty *
Monkey Ubuntu oneiric *
Monkey Ubuntu precise *

References