CVE Vulnerabilities

CVE-2013-1653

Published: Mar 20, 2013 | Modified: Jul 10, 2019
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.1 HIGH
AV:N/AC:H/Au:S/C:C/I:C/A:C
RedHat/V2
RedHat/V3
Ubuntu

Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2, when listening for incoming connections is enabled and allowing access to the run REST endpoint is allowed, allows remote authenticated users to execute arbitrary code via a crafted HTTP request.

Affected Software

Name Vendor Start Version End Version
Puppet Puppet 2.6.0 (including) 2.6.17 (including)

References