CVE Vulnerabilities

CVE-2014-1882

Published: Mar 03, 2014 | Modified: Mar 03, 2014
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

Apache Cordova 3.3.0 and earlier and Adobe PhoneGap 2.9.0 and earlier allow remote attackers to bypass intended device-resource restrictions of an event-based bridge via a crafted library clone that leverages IFRAME script execution and directly accesses bridge JavaScript objects, as demonstrated by certain cordova.require calls.

Affected Software

Name Vendor Start Version End Version
Phonegap Adobe * 2.9.0 (including)
Phonegap Adobe 2.0.0 (including) 2.0.0 (including)
Phonegap Adobe 2.0.0-rc1 (including) 2.0.0-rc1 (including)
Phonegap Adobe 2.1.0 (including) 2.1.0 (including)
Phonegap Adobe 2.2.0 (including) 2.2.0 (including)
Phonegap Adobe 2.2.0-rc1 (including) 2.2.0-rc1 (including)
Phonegap Adobe 2.2.0-rc2 (including) 2.2.0-rc2 (including)
Phonegap Adobe 2.3.0 (including) 2.3.0 (including)
Phonegap Adobe 2.3.0-rc1 (including) 2.3.0-rc1 (including)
Phonegap Adobe 2.3.0-rc2 (including) 2.3.0-rc2 (including)
Phonegap Adobe 2.4.0 (including) 2.4.0 (including)
Phonegap Adobe 2.4.0-rc1 (including) 2.4.0-rc1 (including)
Phonegap Adobe 2.5.0 (including) 2.5.0 (including)
Phonegap Adobe 2.5.0-rc1 (including) 2.5.0-rc1 (including)
Phonegap Adobe 2.6.0 (including) 2.6.0 (including)
Phonegap Adobe 2.6.0-rc1 (including) 2.6.0-rc1 (including)
Phonegap Adobe 2.7.0 (including) 2.7.0 (including)
Phonegap Adobe 2.7.0-rc1 (including) 2.7.0-rc1 (including)
Phonegap Adobe 2.8.0 (including) 2.8.0 (including)
Phonegap Adobe 2.8.1 (including) 2.8.1 (including)
Phonegap Adobe 2.9.0-rc1 (including) 2.9.0-rc1 (including)

References