CVE Vulnerabilities

CVE-2014-1884

Published: Mar 03, 2014 | Modified: Mar 03, 2014
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

Apache Cordova 3.3.0 and earlier and Adobe PhoneGap 2.9.0 and earlier on Windows Phone 7 and 8 do not properly restrict navigation events, which allows remote attackers to bypass intended device-resource restrictions via content that is accessed (1) in an IFRAME element or (2) with the XMLHttpRequest method by a crafted application.

Affected Software

Name Vendor Start Version End Version
Cordova Apache * 3.3.0
Cordova Apache 3.0.0 3.0.0
Cordova Apache 3.0.0 3.0.0
Cordova Apache 3.1.0 3.1.0
Cordova Apache 3.1.0 3.1.0
Cordova Apache 3.2.0 3.2.0
Cordova Apache 3.2.0 3.2.0
Cordova Apache 3.3.0 3.3.0

References