CVE Vulnerabilities

CVE-2015-1122

Published: Apr 10, 2015 | Modified: Mar 08, 2019
CVSS 3.x
N/A
Source:
NVD
CVSS 2.x
6.8 MEDIUM
AV:N/AC:M/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu
MEDIUM

WebKit, as used in Apple iOS before 8.3, Apple TV before 7.2, and Apple Safari before 6.2.5, 7.x before 7.1.5, and 8.x before 8.0.5, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other WebKit CVEs listed in APPLE-SA-2015-04-08-1, APPLE-SA-2015-04-08-3, and APPLE-SA-2015-04-08-4.

Affected Software

Name Vendor Start Version End Version
Safari Apple * 6.2.4 (including)
Safari Apple 7.0 (including) 7.0 (including)
Safari Apple 7.0.1 (including) 7.0.1 (including)
Safari Apple 7.0.2 (including) 7.0.2 (including)
Safari Apple 7.0.3 (including) 7.0.3 (including)
Safari Apple 7.0.4 (including) 7.0.4 (including)
Safari Apple 7.0.5 (including) 7.0.5 (including)
Safari Apple 7.0.6 (including) 7.0.6 (including)
Safari Apple 7.1.0 (including) 7.1.0 (including)
Safari Apple 7.1.1 (including) 7.1.1 (including)
Safari Apple 7.1.2 (including) 7.1.2 (including)
Safari Apple 7.1.3 (including) 7.1.3 (including)
Safari Apple 7.1.4 (including) 7.1.4 (including)
Safari Apple 8.0.0 (including) 8.0.0 (including)
Safari Apple 8.0.1 (including) 8.0.1 (including)
Safari Apple 8.0.2 (including) 8.0.2 (including)
Safari Apple 8.0.3 (including) 8.0.3 (including)
Safari Apple 8.0.4 (including) 8.0.4 (including)
Qtwebkit-opensource-src Ubuntu devel *
Qtwebkit-opensource-src Ubuntu esm-infra/xenial *
Qtwebkit-opensource-src Ubuntu trusty *
Qtwebkit-opensource-src Ubuntu utopic *
Qtwebkit-opensource-src Ubuntu vivid *
Qtwebkit-opensource-src Ubuntu wily *
Qtwebkit-opensource-src Ubuntu xenial *
Qtwebkit-opensource-src Ubuntu yakkety *
Qtwebkit-source Ubuntu devel *
Qtwebkit-source Ubuntu esm-apps/xenial *
Qtwebkit-source Ubuntu precise *
Qtwebkit-source Ubuntu trusty *
Qtwebkit-source Ubuntu utopic *
Qtwebkit-source Ubuntu vivid *
Qtwebkit-source Ubuntu wily *
Qtwebkit-source Ubuntu xenial *
Qtwebkit-source Ubuntu yakkety *
Webkit Ubuntu lucid *
Webkit Ubuntu precise *
Webkitgtk Ubuntu devel *
Webkitgtk Ubuntu esm-apps/xenial *
Webkitgtk Ubuntu trusty *
Webkitgtk Ubuntu utopic *
Webkitgtk Ubuntu vivid *
Webkitgtk Ubuntu wily *
Webkitgtk Ubuntu xenial *
Webkitgtk Ubuntu yakkety *

References