CVE Vulnerabilities

CVE-2015-2320

Improper Certificate Validation

Published: Jan 08, 2018 | Modified: Jan 30, 2018
CVSS 3.x
9.8
CRITICAL
Source:
NVD
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu
MEDIUM

The TLS stack in Mono before 3.12.1 allows remote attackers to have unspecified impact via vectors related to client-side SSLv2 fallback.

Weakness

The product does not validate, or incorrectly validates, a certificate.

Affected Software

Name Vendor Start Version End Version
Mono Mono-project * 3.12.1 (excluding)
Mono Ubuntu devel *
Mono Ubuntu lucid *
Mono Ubuntu precise *
Mono Ubuntu trusty *
Mono Ubuntu trusty/esm *
Mono Ubuntu upstream *
Mono Ubuntu utopic *

Potential Mitigations

References