CVE Vulnerabilities

CVE-2016-7865

Incorrect Type Conversion or Cast

Published: Nov 08, 2016 | Modified: May 16, 2019
CVSS 3.x
8.8
HIGH
Source:
NVD
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.x
9.3 HIGH
AV:N/AC:M/Au:N/C:C/I:C/A:C
RedHat/V2
6.8 CRITICAL
AV:N/AC:M/Au:N/C:P/I:P/A:P
RedHat/V3
8.8 CRITICAL
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Ubuntu
MEDIUM

Adobe Flash Player versions 23.0.0.205 and earlier, 11.2.202.643 and earlier have an exploitable type confusion vulnerability. Successful exploitation could lead to arbitrary code execution.

Weakness

The product does not correctly convert an object, resource, or structure from one type to a different type.

Affected Software

Name Vendor Start Version End Version
Flash_player Adobe * 23.0.0.205 (including)
Red Hat Enterprise Linux 5 Supplementary RedHat flash-plugin-0:11.2.202.644-1.el5_11 *
Red Hat Enterprise Linux 6 Supplementary RedHat flash-plugin-0:11.2.202.644-1.el6_8 *
Adobe-flashplugin Ubuntu devel *
Adobe-flashplugin Ubuntu precise *
Adobe-flashplugin Ubuntu trusty *
Adobe-flashplugin Ubuntu xenial *
Adobe-flashplugin Ubuntu yakkety *
Flashplugin-nonfree Ubuntu devel *
Flashplugin-nonfree Ubuntu esm-apps/xenial *
Flashplugin-nonfree Ubuntu precise *
Flashplugin-nonfree Ubuntu trusty *
Flashplugin-nonfree Ubuntu xenial *
Flashplugin-nonfree Ubuntu yakkety *

References