CVE Vulnerabilities

CVE-2018-11747

Improper Certificate Validation

Published: Mar 21, 2019 | Modified: Dec 16, 2020
CVSS 3.x
9.8
CRITICAL
Source:
NVD
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.x
7.5 HIGH
AV:N/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

Previously, Puppet Discovery was shipped with a default generated TLS certificate in the nginx container. In version 1.4.0, a unique certificate will be generated on installation or the user will be able to provide their own TLS certificate for ingress.

Weakness

The software does not validate, or incorrectly validates, a certificate.

Affected Software

Name Vendor Start Version End Version
Discovery Puppet * *

Potential Mitigations

References