CVE Vulnerabilities

CVE-2020-1133

Improper Privilege Management

Published: Sep 11, 2020 | Modified: Jul 21, 2021
CVSS 3.x
7.8
HIGH
Source:
NVD
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.x
4.6 MEDIUM
AV:L/AC:L/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
Ubuntu

An elevation of privilege vulnerability exists when the Diagnostics Hub Standard Collector improperly handles file operations, aka ‘Diagnostics Hub Standard Collector Elevation of Privilege Vulnerability’. This CVE ID is unique from CVE-2020-1130.

Weakness

The software does not properly assign, modify, track, or check privileges for an actor, creating an unintended sphere of control for that actor.

Affected Software

Name Vendor Start Version End Version
Visual_studio Microsoft 2015 2015
Visual_studio_2017 Microsoft 15.0 *
Visual_studio_2019 Microsoft 16.0 *
Visual_studio_2019 Microsoft 16.5 *
Windows_10 Microsoft - -
Windows_10 Microsoft 1607 1607
Windows_10 Microsoft 1709 1709
Windows_10 Microsoft 1803 1803
Windows_10 Microsoft 1809 1809
Windows_10 Microsoft 1903 1903
Windows_10 Microsoft 1909 1909
Windows_server_2016 Microsoft - -
Windows_server_2019 Microsoft - -
Windows_server_2016 Microsoft 1903 1903
Windows_server_2016 Microsoft 1909 1909
Windows_10 Microsoft 2004 2004
Windows_server_2016 Microsoft 2004 2004

Potential Mitigations

References