CVE Vulnerabilities

CVE-2020-16197

Improper Certificate Validation

Published: Aug 25, 2020 | Modified: Aug 31, 2020
CVSS 3.x
4.3
MEDIUM
Source:
NVD
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 2.x
4 MEDIUM
AV:N/AC:L/Au:S/C:P/I:N/A:N
RedHat/V2
RedHat/V3
Ubuntu

An issue was discovered in Octopus Deploy 3.4. A deployment target can be configured with an Account or Certificate that is outside the scope of the deployment target. An authorised user can potentially use a certificate that they are not in scope to use. An authorised user is also able to obtain certificate metadata by associating a certificate with certain resources that should fail scope validation.

Weakness

The software does not validate, or incorrectly validates, a certificate.

Affected Software

Name Vendor Start Version End Version
Octopus_deploy Octopus 3.4.0 3.4.0
Server Octopus 3.4.0 3.4.0

Potential Mitigations

References