CVE Vulnerabilities

CVE-2021-1224

Improper Privilege Management

Published: Jan 13, 2021 | Modified: Jan 19, 2021
CVSS 3.x
5.3
MEDIUM
Source:
NVD
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
CVSS 2.x
5 MEDIUM
AV:N/AC:L/Au:N/C:N/I:P/A:N
RedHat/V2
RedHat/V3
Ubuntu

Multiple Cisco products are affected by a vulnerability with TCP Fast Open (TFO) when used in conjunction with the Snort detection engine that could allow an unauthenticated, remote attacker to bypass a configured file policy for HTTP. The vulnerability is due to incorrect detection of the HTTP payload if it is contained at least partially within the TFO connection handshake. An attacker could exploit this vulnerability by sending crafted TFO packets with an HTTP payload through an affected device. A successful exploit could allow the attacker to bypass configured file policy for HTTP packets and deliver a malicious payload.

Weakness

The software does not properly assign, modify, track, or check privileges for an actor, creating an unintended sphere of control for that actor.

Affected Software

Name Vendor Start Version End Version
Firepower_management_center Cisco 2.9.14.0 2.9.14.0
Firepower_management_center Cisco 2.9.15 2.9.15
Firepower_management_center Cisco 2.9.16 2.9.16
Firepower_management_center Cisco 2.9.17 2.9.17
Firepower_management_center Cisco 2.9.18 2.9.18
Firepower_management_center Cisco 3.0.1 3.0.1
Firepower_threat_defense Cisco * *

Potential Mitigations

References