CVE Vulnerabilities

CVE-2021-21975

Server-Side Request Forgery (SSRF)

Published: Mar 31, 2021 | Modified: Feb 01, 2022
CVSS 3.x
7.5
HIGH
Source:
NVD
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.x
5 MEDIUM
AV:N/AC:L/Au:N/C:P/I:N/A:N
RedHat/V2
RedHat/V3
Ubuntu

Server Side Request Forgery in vRealize Operations Manager API (CVE-2021-21975) prior to 8.4 may allow a malicious actor with network access to the vRealize Operations Manager API can perform a Server Side Request Forgery attack to steal administrative credentials.

Weakness

The web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure that the request is being sent to the expected destination.

Affected Software

Name Vendor Start Version End Version
Cloud_foundation Vmware 4.0 4.0
Cloud_foundation Vmware 4.0.1 4.0.1
Vrealize_suite_lifecycle_manager Vmware 8.0 8.0
Vrealize_suite_lifecycle_manager Vmware 8.0.1 8.0.1
Vrealize_suite_lifecycle_manager Vmware 8.1 8.1
Vrealize_suite_lifecycle_manager Vmware 8.2 8.2
Cloud_foundation Vmware 3.0 3.0
Cloud_foundation Vmware 3.0.1 3.0.1
Cloud_foundation Vmware 3.0.1.1 3.0.1.1
Cloud_foundation Vmware 3.5 3.5
Cloud_foundation Vmware 3.5.1 3.5.1
Cloud_foundation Vmware 3.7 3.7
Cloud_foundation Vmware 3.7.1 3.7.1
Cloud_foundation Vmware 3.7.2 3.7.2
Cloud_foundation Vmware 3.8 3.8
Cloud_foundation Vmware 3.8.1 3.8.1
Cloud_foundation Vmware 3.9 3.9
Cloud_foundation Vmware 3.9.1 3.9.1
Cloud_foundation Vmware 3.10 3.10
Vrealize_operations_manager Vmware 8.2.0 8.2.0
Vrealize_operations_manager Vmware 8.3.0 8.3.0
Vrealize_operations_manager Vmware 7.5.0 7.5.0
Vrealize_operations_manager Vmware 8.1.0 8.1.0
Vrealize_operations_manager Vmware 8.0.1 8.0.1
Vrealize_operations_manager Vmware 8.1.1 8.1.1
Vrealize_operations_manager Vmware 8.0.0 8.0.0
Vrealize_operations_manager Vmware 7.0.0 7.0.0

References