CVE Vulnerabilities

CVE-2022-0685

Use of Out-of-range Pointer Offset

Published: Feb 20, 2022 | Modified: Nov 07, 2023
CVSS 3.x
7.8
HIGH
Source:
NVD
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.x
6.8 MEDIUM
AV:N/AC:M/Au:N/C:P/I:P/A:P
RedHat/V2
RedHat/V3
7.8 MODERATE
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Ubuntu
MEDIUM

Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 8.2.4418.

Weakness

The product performs pointer arithmetic on a valid pointer, but it uses an offset that can point outside of the intended range of valid memory locations for the resulting pointer.

Affected Software

Name Vendor Start Version End Version
Vim Vim * 8.2.4418 (excluding)
Vim Ubuntu bionic *
Vim Ubuntu esm-infra/bionic *
Vim Ubuntu esm-infra/xenial *
Vim Ubuntu focal *
Vim Ubuntu impish *
Vim Ubuntu jammy *
Vim Ubuntu trusty *
Vim Ubuntu trusty/esm *
Vim Ubuntu upstream *
Vim Ubuntu xenial *

Extended Description

While a pointer can contain a reference to any arbitrary memory location, a program typically only intends to use the pointer to access limited portions of memory, such as contiguous memory used to access an individual array. Programs may use offsets in order to access fields or sub-elements stored within structured data. The offset might be out-of-range if it comes from an untrusted source, is the result of an incorrect calculation, or occurs because of another error. If an attacker can control or influence the offset so that it points outside of the intended boundaries of the structure, then the attacker may be able to read or write to memory locations that are used elsewhere in the product. As a result, the attack might change the state of the product as accessed through program variables, cause a crash or instable behavior, and possibly lead to code execution.

References